Contents Previous Next Subchapters

The O-Matrix Menu Bar


Description
The menu bar offers rapid access to many O-Matrix commands which are controlled primarily through dialogs, secondary windows that contain one or more controls for performing common operations.

File
The File menu can be used to clear the current workspace, create new editor windows, work with existing programs, manipulate files, print output, halt execution, and exiting O-Matrix.

Edit
The Edit menu can be used for cutting, copying, and pasting of text and graphics, editing files, and finding text in files .

Command
The Command menu can be used for executing some common input and output commands such as, including programs for execution and setting numeric output format. In addition, it can be used for profiling the execution speed of your O-Matrix programs.

Debug
The Debug menu can be used to access debugger commands.

Graphics
The Graphics menu can be used to access common graphics commands such as initializing graphics, creating new windows and viewports, manipulating plots, and modifying text.

Options
The Options menu is used for setting preferences at start up and exit such as initial window layout, numeric output formats, and fonts.

Window
The Window menu can be used to access windows and control their layout within the O-Matrix workspace.

Tools
The Tools menu contains items that have been added by an O-Matrix program using the addmenu command.

Help
The Help menu can be used to display the help that is distributed with O-Matrix and add on packages.